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Introduction 

Welcome to MadCap Feedback and the MadCap Feedback Explorer, which let you track live user 
feedback on your MadCap Flare online documentation—not only for Web-based Help, but also for 
desktop Help such as Microsoft HTML Help and DotNet Help. 

Getting Started 
The following will help you get started quickly with MadCap Feedback and the MadCap Feedback 
Explorer: 

 About MadCap Feedback Learn the basics of MadCap Feedback. See "About MadCap 
Feedback" on page 6. 

 About the MadCap Feedback Explorer Learn the basics of the MadCap Feedback Explorer, 
including the way that it works in conjunction with MadCap Feedback and your Flare online 
output. See "About the MadCap Feedback Explorer" on page 7. 

 Feedback Explorer—Internal Versus External View a table that compares the features 
available in the internal Feedback Explorer with those in the external Feedback Explorer. See 
"Feedback Explorer—Internal Versus External" on page 8. 

 Getting Set Up Check out the basic steps that are necessary for configuring your system and 
using MadCap Feedback. See "Getting Set Up with MadCap Feedback" on page 13. 

 Tour the Workspace Become familiar with the Feedback Explorer's user interface. See 
"Touring the Feedback Explorer Workspace" on page 25. 
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About MadCap Feedback 
MadCap Feedback is a live Help reporting service that works in conjunction with Flare to provide Web 
2.0 community benefits for your online output—including integrated user comments and statistics such 
as search keywords used and topics visited. Most of these benefits are available not only for Web-based 
Help (i.e., WebHelp and WebHelp Plus), but also for desktop Help (i.e., Microsoft HTML Help and 
DotNet Help).  

You have two options when setting up MadCap Feedback: 

 MadCap Feedback Server With MadCap Feedback Server, you install the necessary software 
on your own hardware to host the Feedback data. By using the MadCap Feedback Server 
Admin, your system administrator (or other responsible individual) can enter the appropriate 
server information, create the necessary SQL database, and perform maintenance tasks such as 
scheduling automated backups of the data. Authors can use the Feedback license keys that are 
issued as needed for their various targets and projects. The Flare output files can be hosted on 
the same server hosting the Feedback data, but it is not mandatory; the output files can be 
published anywhere you like. 

 MadCap Feedback Service With MadCap Feedback Service, there is no need to purchase 
your own hardware or host the Feedback statistics. MadCap Software does the hosting for you. 
This does not mean, however, that you publish the output files to MadCap Software's server. 
Instead, you publish the output files to your own server or anywhere else that you choose. 
Even if you have attached your online Help to a desktop application, you can still take 
advantage of the Feedback features. 
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About the MadCap Feedback Explorer 
The MadCap Feedback Explorer provides an interface that lets you view and track reader activity on 
your Flare online output. There are two versions of the Feedback Explorer: internal and external. 

 Internal Feedback Explorer This is a light version of the Feedback Explorer that is part of 
the Flare interface. It lets you view user activity for the primary target (as well as any other 
targets using the same Feedback license). You can open this window in Flare by selecting 
View>Feedback Explorer. For more information, see the Flare online Help. 

 External Feedback Explorer This is a standalone application that is separate from Flare, and 
it is a more robust version than the internal Feedback Explorer, containing more features. It 
displays user activity for the most recently opened Feedback file (which is associated with a 
target/license combination in Flare).   

How It Works  

The following diagram illustrates how the Feedback Explorer works with MadCap Feedback and MadCap 
Flare output.  
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Feedback Explorer—Internal Versus External 
The following table shows all Feedback tasks that can be performed in the light version of the Feedback 
Explorer (located in the Flare interface), compared with those that can be performed in this more 
robust, external version of the Feedback Explorer. 

Feature Task 
Internal 

Feedback 
Explorer 

External 
Feedback 
Explorer 

Active users Export to CSV file   X 

  Export to TXT file   X 

  View   X 

Administrators Add   X 

  Remove   X 

Charts Create   X 

  Edit chart styles   X 

Comments (author-
only) 

Export to CSV file X X 

  Export to TXT file X X 

 View all author-only comments X X 

Comments (community-
wide) 

Accept X X 

  Discard X X 

  Enable/disable anonymous 
comments 

  X 

  Export all comments to CSV file  X X 

  Export all comments to TXT file  X X 

  Export pending comments to CSV  X X 

  Export pending comments to 
TXT file 

X X 

  Require comments to be reviewed   X 

 View community-wide comments X X 
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Feature Task 
Internal 

Feedback 
Explorer 

External 
Feedback 
Explorer 

Feedback files 
(configured with target) 

Clear (remove data from Feedback 
database) 

 X 

 Create*   X 

  Open*   X 

Reviewers (for 
approving comments) 

Add   X 

  Remove   X 

Search phrases Export to CSV file† X X 

  Export to TXT file† X X 

  View all search phrases used† X X 

  View searches without results† X X 

Synonyms (to enhance 
search results) 

Create*†   X 

Topic ratings Export to CSV file  X X 

  Export to TXT file  X X 

  View all topic ratings X X 

  View average rating per topic   X 

Topics Export list of visited topics to CSV    X 

 Export list of visited topics to TXT    X 

 View list of visited topics   X 

* This feature cannot be performed in the internal Feedback Explorer, but it can be performed 
elsewhere in Flare. 

† This feature is available if you are generating DotNet Help, WebHelp, or WebHelp Plus output formats 
only. It is not available for Microsoft HTML Help output. 
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Getting Additional Help 
If you need additional help beyond the information provided in this manual, you can use any of the 
following resources. 

Online Help  

Open the online Help system in the Feedback Explorer and look for the information you need. You can 
do this in a variety of ways: 

 Use the Dynamic Help pane. Select Help>Dynamic Help or press CTRL+F3. The 
Dynamic Help pane opens (by default on the right side of the interface) and will display the 
appropriate Help topics as you click in different areas of the workspace. 

 Use context-sensitive Help without the Dynamic Help pane. Press F1 to open the 
appropriate topic for the active area of the workspace. 

 Use the table of contents. Select Help>Contents or press CTRL+ALT+F1. This opens the 
online Help TOC (by default on the left side of the interface). Navigate through the TOC books 
and pages to find the information you need. When you click a topic page, it displays in the 
workspace. 

 Use the index. Select Help>Index or press ALT+F1. This opens the online Help index (by 
default on the left side of the interface). Navigate through the index to find keywords for the 
information you need. Also, open the Index Results window by selecting Help>Index Results 
or pressing ALT+SHIFT+F2. When you click a keyword in the index, the associated topic links 
are listed in the Index Results window. Click any of the links to open a specific topic. 

 Use the search feature. Select Help>Search or press CTRL+F1. This opens the Help 
Search window (by default on the left side of the interface). Enter one or more keywords in the 
field and click Search. Links to topics containing those keywords are listed below. When you 
click a topic link, that topic displays in the workspace. 

 Use the glossary. Select Help>Glossary. This opens the Help glossary (by default on the 
left side of the interface). Click any of the terms in the glossary to see a definition. 
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Knowledge Base 

Browse the online Knowledge Base for articles covering the most common support issues. You can 
access the Knowledge Base from: 

http://kb.madcapsoftware.com/ 

Peer-to-Peer Online Forums 

Visit the online forums to learn from other MadCap Feedback users or share your own expertise. You 
can access the online forums from: 

http://forums.madcapsoftware.com/ 

Contact MadCap Feedback Support 

Contact the MadCap support team and get answers to your specific support issues. Simply go to: 

http://madcapsoftware.com/support/feedbacksupport.aspx 

http://kb.madcapsoftware.com/
http://forums.madcapsoftware.com/
http://madcapsoftware.com/support/feedbacksupport.aspx
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Getting Set Up with MadCap Feedback 

Getting set up to use MadCap Feedback involves the following basic steps: 

1. Install MadCap Feedback Server This step needs to be completed only if you have 
purchased the MadCap Feedback Server (as opposed to the MadCap Feedback Service). Provide 
your system administrator (or other responsible individual) with the instructions that are 
necessary for installing the software and other components. See "Installing MadCap Feedback 
Server" on page 15. 

2. Configure Feedback Server Admin This step needs to be completed only if you have 
purchased the MadCap Feedback Server (as opposed to the MadCap Feedback Service). Provide 
your system administrator (or other responsible individual) with the instructions that are 
necessary for configuring the MadCap Feedback Server Admin. This includes the ability to test 
the settings, set up an SMTP server for email notifications, specify redirection Web pages for 
end users who register, and schedule automatic backups of the database and transaction log. 
See "Configuring the MadCap Feedback Server Admin" on page 18. 

3. Install external Feedback Explorer Each user on your team who plans to use the external 
Feedback Explorer to view user comments and statistics should install this software locally. This 
includes managers who do not use Flare but want to be kept informed about user activity on 
the published Help output. A light version of the Feedback Explorer is built in to Flare. For more 
information and the differences between these versions of the Feedback Explorer, see 
"Feedback Explorer—Internal Versus External" on page 8. 

4. Obtain Feedback license(s) You need a separate Feedback license for each Flare target that 
you want to track. After you purchase the MadCap Feedback Server or Service, you will be 
issued the appropriate Feedback license(s) from MadCap Software.  

E X A M P L E  

Let's say you have three authors and a manager on your team. You have a 
total of f ive dif ferent Flare projects, and from each of those projects, you 
and the other authors are generating two onl ine targets. So as a team, you 
are producing a total of ten onl ine outputs (two targets each from five 
projects). How many Feedback l icenses are needed so that the authors and 
manager can track the user activity for al l of those targets? In this case, 
you would need ten l icenses (one for each output that you want to track).  

Note: It is possible to use the same Feedback license for different Flare targets. However, 
you must keep in mind that the statistics for the various targets will then become merged 
when you view them in the Feedback Explorer. You will not be able to determine which 
statistics resulted from which targets. 
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5. Enable Feedback in Flare targets After obtaining the necessary Feedback license(s), you 
need to enable the Feedback functionality in Flare. Each user on your team who will be 
generating output for a particular target needs to do this in his or her copy of the Flare project. 
Even if three different users will be working on the same Flare project, each of those authors 
enters the same Feedback license for the same target. For more, see the Flare online Help. 

6. Configure Flare target with external Feedback Explorer See "Creating and Opening a 
Configured Feedback File" on page 23. 

7. Enable comments in the skin If you want end users to be able to enter community-wide 
Feedback comments in the online output and view recent comments, you need to enable 
community-wide comments. This is done by opening the skin in Flare that is associated with 
the target and selecting the appropriate option(s). For steps, see the online Help in Flare. 
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Installing MadCap Feedback Server 
If you purchase MadCap Feedback Server (as opposed to the MadCap Feedback Service), you need to 
install the Feedback Server Admin on the Microsoft Windows machine that will be used to host your 
Feedback data. Provide the individual who is responsible for the installation with these instructions. 

Requirements 

 Windows operating system (the following are supported): 

o  Microsoft Windows 2000 

o  Microsoft Windows 2000 Server 

o  Microsoft Windows XP 

o  Microsoft Windows Server 2003 

 Microsoft .NET Framework 2.0 (free download from microsoft.com) 

 SQL Server (the following are supported): 

o SQL Server 2005 Standard 

o SQL Server 2005 Express (free download from msdn.microsoft.com) 

o SQL Server 2000 

 Microsoft Internet Information Services (IIS) 

 ASP.NET 2.0 

 MadCap Feedback Server Admin 

Keys 

When you purchase MadCap Feedback Server, you are issued two types of keys: 

 Feedback Server Key You will be issued one key. Use this key to activate MadCap Feedback 
Server Admin on the machine hosting the Feedback data. 

 Feedback License Keys You will be issued a set number of keys. Authors use one of these 
keys for each of their Flare targets that they want to track. 

http://microsoft.com/
http://msdn.microsoft.com/
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How to install MadCap Feedback Server Admin and other components 

On the same machine to be used for hosting the Feedback, complete the following steps. 

1. Make sure that Microsoft .NET Framework is installed. 

2. Make sure that a supported version of SQL Server is installed. 

Note: If you do not have SQL Server installed, you can download SQL Server 2005 Express 
for free from msdn.microsoft.com. 

3. Make sure that Microsoft IIS is installed. If it is not, use the following steps: 

a. Open the Control Panel. On many computers, you can do this by clicking 
Start>Control Panel. 

b. Double-click Add or Remove Programs. 

The Add or Remove Programs window opens. 

c. Click Add/Remove Windows Components. 

The Windows Components Wizard opens. 

d. Click the check box next to Internet Information Services (IIS) to add a check 
mark. 

e. Click Next. 

f. Click Finish.  

3. Make sure that ASP.NET is installed. If it is not, use the following steps: 

a. Click Start>Run. 

The Run dialog opens. 

b. In the Open field, enter the following into the field:  

C:\WINDOWS\Microsoft.NET\Framework\v2.0.50727\aspnet_regiis -i 

c. Click OK. 

A window opens, displaying the installation progress of ASP.NET. The window will close 
automatically when the installation finishes. 

Note: If you are using Windows Server 2003, please note that ASP.NET pages by default 
are prohibited in IIS. Therefore, you must set these pages to be allowed if you are running 
Windows Server 2003. To do this: (1) In Internet Information Services (IIS) Manager, 
select Web Service Extensions from the left pane; (2) in the right pane, make sure that 
ASP.NET v2.0.50727 is set to Allowed. If it is not, select it and click the Allow button. 

http://msdn.microsoft.com/
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4. Insert the CD (for boxed version purchases) or download the MadCap Feedback Server Admin 
application from the link you received (for online purchases). Install the application. 

a. As soon as you complete the steps in the installation wizard and finish registering your 
copy of MadCap Feedback Server Admin, the Feedback Server Setup dialog opens. 
Click the down arrow in the SQL Server field and select your SQL Server. 

Note: If you are using SQL Server 2000, you must make sure that Microsoft SQL 
Server 2005 Management Objects Collection is installed on the machine. If you do 
not have this installed, it can be downloaded from: 
http://www.microsoft.com/downloads/details.aspx?FamilyId=D09C1D60-A13C-
4479-9B91-9E8B9D835CDC&displaylang=en. Please note that the Microsoft SQL 
Server 2005 Management Objects Collection requires Microsoft Core XML Services 
(MSXML) 6.0 and Microsoft SQL Server Native Client, which are available from the 
same link. 

b. (Optional) You can select a location for the database other than the default location 
provided. To do this, next to the Database Location field, click the Browse button. 
Then find and select the folder where you want the database to be stored. 

c. In the last field of the Feedback Server Setup dialog, select the Web site where you 
want MadCap Feedback Server installed. If you have not set up a specific Web site for 
this purpose, use the default. 

d. Click OK. 

The installation is complete and the MadCap Feedback Server Admin opens with three 
tabs shown (Basic, Advanced, Maintenance). You can use these tabs to configure the 
admin and set up maintenance tasks. (The Maintenance tab is used only for SQL 
Server 2005 Express.) See "Configuring the MadCap Feedback Server Admin" on page 
18. 

Note: The machine used to host the Feedback data can also be used to host the author’s online 
Help output. However, this is not mandatory. The author may publish the output elsewhere. 

Note: If you are using Microsoft Windows XP, you may need to add IIS to the windows firewall in 
order for MadCap Feedback to function fully.  

http://www.microsoft.com/downloads/details.aspx?FamilyId=D09C1D60-A13C-4479-9B91-9E8B9D835CDC&amp;displaylang=en
http://www.microsoft.com/downloads/details.aspx?FamilyId=D09C1D60-A13C-4479-9B91-9E8B9D835CDC&amp;displaylang=en
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Configuring the MadCap Feedback Server Admin 
After you install the MadCap Feedback Server Admin and the other necessary components, you can 
open the admin to do any of the following: 

 Set up an SMTP server for various email notifications  

 Test your settings  

 Specify redirection Web pages for end users who register to enter Feedback comments  

The author can configure MadCap Feedback to require end users to register before submitting 
community-wide comments. After the end user registers, a specific Web page displays, 
depending on whether the registration was successful. You can use the Feedback Server Admin 
to specify the pages that end users see when successful or unsuccessful registrations occur. 

 Schedule automatic backups of the database and transaction log  

How to configure and maintain the MadCap Feedback Server Admin  

1. Open the Feedback Server Admin application.  

2. Select the Basic tab.  

Notice that the server and Web site that you selected during installation are populated.  

3. In the SMTP Server section, enter the appropriate server, user name, and password. This is 
the server that will be used to support the Feedback comments that end users can submit, as 
well as to send emails for the user registration process. If you have an existing SMTP server 
(such as Microsoft Exchange) set up, you can use it for this purpose. In the "From" Address 
field, enter the email address that you want email notifications to contain in the "From" field. 

Note: If you elect to use Windows Integrated Authentication, leave the user name and 
password fields blank. Otherwise, if your SMTP server requires specific credentials, specify 
them in the provided fields.  

4. (Optional) You can click the Test button next to any of the sections on this tab to make sure 
that SQL Server, Web site, and SMTP Server are working.  

If you click the Test button in the SMTP Server section, a dialog opens, letting you enter an 
email address for sending a test email.  

5. Select the Advanced tab.  
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6. In the Activation success page field, enter the URL to the Web page that you want to be 
displayed if the registration process is successful. 

7. In the Activation failure page field, enter the URL to the Web page that you want to be 
displayed if the registration process is unsuccessful.  

8. Select the Maintenance tab. 

Note: The tasks on the Maintenance tab are applicable to SQL Server 2005 Express only. If 
instead you have SQL Server 2005 Standard, you can perform these remaining 
maintenance tasks in that application (see the steps on the following pages). If you are 
using SQL Server 2000, refer to its documentation for help on performing maintenance 
tasks.  

9. In the Location field, enter the path where you want backups of the database and transaction 
log to be stored.  

10. In the Day & Time field, specify whether you want the backups to be created daily or weekly. 
Also, specify the day and time when you want the backup process to run. 

In the SQL Server Express Maintenance Service section, the Start button should already be 
engaged. This enables backups to be created. Backups will be created for the database and the 
transaction log. In addition, this action "shrinks" the transaction log (which steadily grows over 
time).  
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How to set up a maintenance plan in SQL Server 2005 Standard 

The following prerequisites, steps, and verification process are necessary only if you are working with 
SQL Server 2005 Standard. They are not necessary for SQL Server 2005 Express.  

Note: If you are using SQL Server 2000, refer to its documentation for help on performing 
maintenance tasks. 

 Prerequisites: 

 Install Microsoft SQL Server Management Studio (not SQL Server Management Studio Express) 
and Integration Services: 

a. Run the SQL Server 2005 setup from the SQL Server 2005 installation disk. 

b. In Feature Selection, click Advanced. 

c. Click Integration Services and select Will be installed on local hard drive. 

d. Similarly, under Client Components, click Management Tools and select Will be 
installed on local hard drive. 

e. Click Next and finish the setup. 

 Make sure SQL Server Agent is running and set to run automatically when Windows starts up: 

a. Select Start>Programs>Microsoft SQL Server 2005>Configuration 
Tools>SQL Server Configuration Manager. 

b. Select SQL Server 2005 Services. 

c. In the right pane, ensure that SQL Server Agent is running and starts on Windows 
startup: 

i. Right-click SQL Server Agent and select Properties. 

ii. Under the Service tab, make sure Start Mode is set to Automatic. 

iii. Click OK. 

iv. Right click SQL Server Agent again and select Start. If Start is grayed out 
but Stop is not, then it is already started. 

 Steps: 

1. Open Microsoft SQL Server Management Studio: 

a. Select Start>Programs>Microsoft SQL Server 2005>SQL Server Management 
Studio. 

b. In the Connect to Server dialog, select your SQL Server from the Server name drop-
down.  

c. Click Connect. 
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2. In the Object Explorer, expand Management. 

3. Right-click Maintenance Plans and select Maintenance Plan Wizard.  

The Maintenance Plan Wizard opens. 

4. Click Next. 

5. On the Select a Target Server page, click in the Name field and enter a name for this 
maintenance plan (e.g., "Feedback Server Maintenance Plan").  

6. Click Next. 

7. On the Select Maintenance Tasks page, place a check mark next to: 

 Shrink Database 

 Back Up Database (Full) 

 Back Up Database (Transaction Log) 

8. Click Next. 

9. On the Select Maintenance Task Order page, use the Move Up and Move Down buttons 
to configure the three previous tasks in the following order from top to bottom:  

 Back Up Database (Full) 

 Back Up Database (Transaction Log) 

 Shrink Database 

10. Click Next. 

11. On the Define Back Up Database (Full) Task page, click the down arrow next to the 
Databases field and place a check mark next to MadCapFeedbackServer.  

12. Click OK. 

13. (Optional) Next to the Folder field, you can select the folder where the backup will be saved. 

14. Click Next.  

15. On the Define Back Up Database (Transaction Log) Task page, click the down arrow next 
to the Databases field and place a check mark next to MadCapFeedbackServer.  

16. Click OK.  

17. (Optional) Next to the Folder field, you can select the folder where the backup will be saved. 

18. Click Next.  

19. On the Define Shrink Database Task page, click the down arrow next to the Databases 
field and place a check mark next to MadCapFeedbackServer.  

20. Click OK.  

21. In the field labeled Shrink database when it grows beyond, enter 1 so that the database 
shrinking occurs when the database is larger than 1 MB. 

22. Click Next.  

23. On the Select Plan Properties page, click Change to define a maintenance schedule. 

The New Job Schedule dialog opens. 
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24. In the Name field, type a name for this schedule (e.g., "Feedback Server Maintenance 
Schedule").  

25. From the Occurs drop-down menu, select Daily.  

26. (Optional) In the field labeled Occurs once at, you can select a time you prefer the 
maintenance plan to be executed or use the default (12:00:00 AM). It is recommended that the 
maintenance plan run during a time when there is the least amount of traffic using the 
database. 

27. Click OK. 

28. In the Maintenance Plan Wizard, click Next.  

29. (Optional) On the Select Report Options page, you can select to have a report written to a 
text file after each time the maintenance plan is executed. To do so, place a check mark next to 
Write a report to a text file.  

30. (Optional) Next to Folder location, you can select the folder where the text file will be saved. 

31. Click Next.  

32. The Complete the Wizard page shows a summary of the options that you selected. Review 
them and click Finish. 

33. The Maintenance Plan Wizard Progress page displays the progress of creating the maintenance 
plan. After it is completed, click Close.  

 Verify the maintenance plan: 

1. Open Microsoft SQL Server Management Studio 

2. In the Object Explorer, expand Management. 

3. Expand Maintenance Plans.  

4. Right-click Maintenance Plans and select Refresh to ensure that all maintenance plans are 
displayed. The new maintenance plan should appear in the list.  

5. On the same level as Maintenance Plans, expand SQL Server Agent.  

6. Expand Jobs.  

7. Right-click Jobs and select Refresh to ensure that all jobs are displayed. A new job should 
appear in the list with the same name as the maintenance plan you created.  

8. To test executing the maintenance plan, right-click the job and select Start job.  

A dialog appears, displaying the progress and status of the job. All statuses should show 
"Success."  

9. Using Windows Explorer, browse to the various locations you chose to save the database 
backup, transaction log backup, and report text file. Verify that each file exists.  
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Creating and Opening a Configured Feedback File 
One of the first tasks that must be performed in the Feedback Explorer is to create or open a file that is 
configured with a target in MadCap Flare. You can initialize this task from the Feedback Explorer or from 
within Flare. It is easiest to create and open the initial Feedback file from within Flare. The reason for 
this is that you only need to enter your Feedback license once. After entering the license key in Flare's 
Target Editor, simply click the button labeled Configure with Feedback Explorer Application.  

However, some individuals may want to perform this task from the Feedback Explorer. For example, 
some people (such as managers) may not work in MadCap Flare, but want to track user activity in the 
author's online Help files.  

Configuring a Flare target from the Feedback Explorer is a one-time setup process where the Feedback 
file is created and opened. After this initial setup, you can open that Feedback file whenever you want 
to view or take action on user activity. Following are steps for creating the initial configured Feedback 
file from the external Feedback Explorer, followed by steps for opening an existing configured Feedback 
file.  For more information about creating the configuration file from Flare, see the Flare online Help. 

How to create the initial configured Feedback file 

1. Do one of the following: 

 In the Standard toolbar, click . 

 Select File>New. 

 Press CTRL+N on your keyboard. 

The New Local Target dialog opens.   

2. In the Feedback Server field, enter the path to the server hosting the data. If you purchased 
the MadCap Feedback Service (as opposed to the MadCap Feedback Server), enter madcap, 
which maps to feedbackserver.madcapsoftware.com. 

Note: It is highly recommended that you purchase an SSL certificate and install it on your 
Web server. MadCap Feedback uses encryption for certain processes, which helps to 
ensure that the data transfer is secure. If you have an SSL certificate installed on your Web 
server, make sure you begin the path to the server with https://. 

3. In the Feedback Key field, enter the Feedback license that you have been issued. 

4. Click OK. The Feedback file (with an .fbconf extension) opens in the Feedback Admin. The file 
has no name until you save it. 

5. Click  to save your work. 

6. In the Save As dialog, enter a name for the new Feedback file (perhaps naming it after the 
Flare target or project). 

7. Click Save. 

8. In Flare, open the target and enter the same Feedback license that you entered for the 
Feedback file. This step does not apply to you unless you are an individual responsible for 
working in the Flare project. If you are a manager who simply wants to view the user activity, 
ignore this step. 
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How to open a configured Feedback file 

1. Do one of the following: 

 In the Standard toolbar, click . 

OR 

 Select File>Open. 

OR 

 Press CTRL+O on your keyboard. 

2. Locate and double-click the Feedback file (.fbconf extension) that you want to open. 

Note: By default, Feedback files are stored in a folder labeled "My Feedback Admin," which is 
automatically created for you and placed in your My Documents folder. 

Clearing the Feedback Database 
You can wipe out your Feedback database so that all data (including all comments, topic ratings, and 
search queries) are removed from it. You might use this button, for example, if you have been testing 
the Feedback Service and want to publish your output without users seeing your test data. 

How to clear the Feedback database 

1. Open the Feedback file. 

2. In the local toolbar of the Feedback Admin, click . 

3. In the dialogs that open, click Yes. 

The next time you launch the Feedback Explorer and open that Feedback file, the data will be 
gone. 

 

- 24 -  



Chapter 3 

- 25 - 

Touring the Feedback Explorer Workspace 

The Feedback Explorer's user interface consists of three major sections: 

 Left The left side of the interface is the default location for many different window panes (e.g., 
Pending Comments, Search Phrases), which can be used to view and work with information 
gathered from user activity on your online output.  

 Middle The large middle section of the interface is the default location for the main editor in 
the Feedback Explorer (the Feedback Admin), which is used to configure the way that MadCap 
Feedback works. This middle section also displays other editors and the Start Page. 

 Right The right side of the interface (like the left side) is the default location for additional 
window panes (e.g., Dynamic Help window, Chart window). 
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As mentioned, the three main areas of the interface are the default locations for these many elements. 
However, you have the flexibility in the Feedback Explorer to close or move elements around as you 
like, so it is not mandatory that every window or editor remain permanently in its default location. 

In addition to the three main areas mentioned, the Feedback Explorer's interface also consists of menus 
and toolbars, which also support the tasks that you perform.  

Following are overviews of the different areas of the Feedback Explorer interface, highlighted by some 
of the most important elements that you will encounter as you work in the Feedback Explorer. 

Start Page 
The Start Page is a handy window that displays when you first launch the Feedback Explorer and 
remains open unless you close it. This window consists of three sections (Open an Existing File, Getting 
Started, and News and Updates), which contain links to high-level tasks and information.   
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Feedback Admin 
The Feedback Admin serves as the main control panel for configuring a Feedback file, which acts as the 
connector between the Feedback Explorer and the Flare target to be tracked. This editor is used to 
perform tasks such as enabling anonymous comments, requiring new comments to be reviewed, adding 
administrators, and adding reviewers.  
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Window Panes 
The Feedback Explorer has numerous window panes in the interface that are used for a variety of 
purposes, such as viewing user comments, search phrases entered, and topic ratings. Most of these 
panes are located by default on the left side of the workspace, whereas other panes (such as the Chart 
window) are located on the right side. If more than one window pane is open on either side, the panes 
are organized in an accordion structure. This means that they are stacked on top of each other, with 
the active window pane displayed "in front" of the other panes. Accordion bars for each window pane 
are located at the bottom, and you can click any bar to bring that particular window pane "in front" so 
that you can use it.  
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Menus 
The Feedback Explorer's user interface includes a menu bar at the top of the program window, 
containing several menu options. Of particular importance is the "View" menu, which is used to open 
the many different window panes that you will use to see and work with user statistics and information.  

 

Standard Toolbar 
Tools in the Standard toolbar let you perform basic functions, such as Save, Cut, Copy, Paste, Undo, 
and Redo. There are also shortcut buttons for opening the many different window panes in the 
interface. To see this toolbar, select View>Toolbars>Standard.  
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Customizing the Feedback Explorer Workspace 
One of the benefits of the Feedback Explorer's user interface is that it is flexible and easy to customize 
to meet your needs. Following are some of the ways you can customize the workspace.  

Moving, Docking, and Floating Window Panes 

Simply because a window pane is attached to the left or right side of the program window by default, 
this does not mean it has to stay there.  

 Moving windows You can move a window pane wherever you want it by clicking the "Drag 
Pane" section  (located in the upper-left corner of the window pane) and dragging the 
window where you want it.  

 Floating windows If you drop the window pane at a random location in the program window, 
it becomes a "floating" window. (You can also create a floating window by clicking in the 
element and selecting Window>Floating.) 

 Docking windows "Docking" a window means to "attach it" to an edge of the program 
window. To do this, move the floating window pane by clicking in the title bar of the window 
pane, drag it to the edge where you want to dock it, and drop it onto one of the blue arrows or 
bulls eyes that appear in the interface.  

Auto-Hiding Window Panes  

In the top-right corner of every window pane, you will see a small button that looks like a pin . If you 
click this button, the window pane is hidden (or "pinned" to the edge of the program window). 
However, you can still see the title of the window pane along the edge of the program window. When 
you hover the mouse over the title, the window pane temporarily displays again until you move the 
mouse off the window pane. Click the button again to "un-pin" the window pane. 

Resizing User Interface Elements 

You can easily resize the program window, dialog windows, and floating window panes in the Feedback 
Explorer by clicking the edge of the element and dragging the mouse to the desired size. You can also 
resize drop-down menus in the same way. 

Customizing Column Information 

In certain windows and editors in the Feedback Explorer (e.g., Search Phrases window, Topics window), 
information is presented in columns. You can configure the way that these columns are displayed. For 
example, you can hide or show certain columns, set a background color for a column, or increase the 
width for a column. You can also specify which column information should be included when creating a 
chart from the statistics in the window. 
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Window Layouts 
When you move window panes or editors around in the interface, the configuration (or "layout") of the 
workspace is changed. You can do several things with layouts, including the following: 

 Save You can save different layouts of the interface, in case you want to use them for different 
purposes.  

 Auto-save You can automatically save the layout of the workspace when you exit the 
Feedback Explorer. The next time you launch the application, that same layout will be 
displayed. 

 Select You can quickly change the configuration of your workspace by selecting a window 
layout that you have saved previously.  

 Reset You can return the workspace configuration to the original layout that you saw when 
you first installed and launched the Feedback Explorer. 

 Reload You can return the workspace to the saved configuration of the layout. In other words, 
if you are working in a particular layout and have opened different interface elements or moved 
interface elements around, you can select this option to go back to the saved configuration. 

 Lock You can freeze a window layout so that the window panes and editors cannot be moved 
floated or docked to different areas of the interface. 

 Delete You can open the Manage Window Layouts dialog, which lets you select or delete an 
existing layout.  

How to save a window layout 

1. Configure the workspace how you want it.  

2. Select Window>Layouts>Save Window Layout As.  

3. In the Rename Window Layout dialog, enter a name for the layout.  

4. Click OK.  

How to auto-save a window layout 

 Select Window>Layouts>Auto-save Layout.  

How to select a saved window layout 

 Select Window>Layouts>Select Layout>[Name of Layout].  

How to reset the window layout 

 Select Window>Layouts>Reset Window Layout.  
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How to reload the window layout 

 Select Window>Layouts>Reload Window Layout.  

How to lock a window layout 

 Select Window>Layouts>Lock Window Layout.  

How to delete a window layout 

1. Select Window>Layouts>Layouts.  

The Manage Window Layouts dialog opens. 

2. Select the layout that you want to delete. 

3. Click Delete. 

4. Confirm the deletion by clicking OK. 

5. Click Close. 
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Features 

The Feedback Explorer offers an extensive list of features to assist you in working with MadCap 
Feedback, including the following: 

Administrators and Reviewers 

 About administrators and reviewers (see page 35) 

 Adding administrators (see page 35) 

 Adding reviewers (see page 35) 

Topics 

 Viewing topics opened by users (see page 36) 

Topic Ratings 

 About topic ratings (see page 36) 

 How end users submit topic ratings (see page 37) 

 Viewing topic ratings (see page 38) 

Comments 

 About comments (see page 39) 

 Specifying whether new comments need to be reviewed (see page 41) 

 Enabling anonymous comments (see page 41) 

 How end users submit community-wide comments (see page 42) 

 How end users submit author-only comments (see page 44) 

 Viewing topic comments (see page 45) 

 Accepting pending comments (see page 46) 

 Hiding community-wide comments (see page 47) 

 Setting community-wide comments to Pending status (see page 47) 

 Discarding pending comments (see page 48) 

 Replying to community-wide comments (see page 48) 

 Viewing active users (see page 49) 
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Search 

 About search (see page 50) 

 Viewing used search phrases (see page 50) 

 Viewing searches without results (see page 51) 

 Creating synonyms to enhance search results (see page 51) 

Charts 

 About charts (see page 53) 

 Creating Feedback charts (see page 54) 

 Editing charts (see page 55) 

 Printing charts (see page 56) 

Exporting 

 About exporting (see page 57) 

 Exporting Feedback data to Microsoft Excel, using a CSV file (see page 57) 

 Exporting Feedback data to a tab-delimited text file (see page 58) 

 Exporting synonyms (see page 59) 
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Administrators and Reviewers 
You can set up a Feedback file so that you and other individuals are notified when certain user activity 
takes place on your Help output. 

 Adding administrators You can specify individuals who should be emailed when the 
following activities take place: users submit new community-wide comments, the status for a 
community-wide comment is changed, or the Feedback database is cleared. An administrator 
might be an individual such as a manager or documentation leader who will not necessarily 
take action on user activity but still needs to be kept informed. See "How to add administrators 
to the email list" on page 35. 

 Adding reviewers You can specify individuals who should be emailed when users submit new 
community-wide comments in the published online output. In addition to yourself, reviewers 
can be other writers on your documentation team. These individuals will be emailed only if you 
have specified that comments require review before being published (see page 41). They can 
then open the Feedback Explorer to take action on pending comments (e.g., accepting, 
discarding, hiding) as necessary. See "How to add reviewers to the email list" on page 35. 

Note: It is not mandatory that you add reviewers to this list. It is simply an activity that 
helps speed the process of accepting new comments because it notifies the appropriate 
individuals when action is needed for pending comments. Anyone who has the Feedback 
Explorer installed with the appropriate Feedback license key will be able to take action on 
pending comments, even if they are not added to the reviewers notification list. 

How to add administrators to the email list 

1. Open the Feedback file. 

2. In the Feedback Admin, select the Administrators tab. 

3. Enter the email addresses of the individuals who will be administrators for the associated Flare 
output. Use a separate line for each email address, pressing Enter after you add an address. 

4. Click  to save your work. 

How to add reviewers to the email list 

1. Open the Feedback file. 

2. In the Feedback Admin, select the Reviewers tab. 

3. Enter the email addresses of the individuals who will be reviewers for the associated Flare 
output. Use a separate line for each email address, pressing Enter after you add an address. 

4. Click  to save your work. 
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Topics 
You can use the Topics window to view a list of all the topics that users have opened in your output. 
This includes a count of how many times each topic has been opened, as well as its average rating from 
users and the number of comments that have been submitted. 

How to view topics opened by users 

1. Open the Feedback file. 

2. Open the Topics window. (If it is not already displayed in the interface, select View>Topics.) 

You can see information on the topic path, view count, comment count, average rating, and 
rating count. 

Note: You may need to refresh the window to make sure you see the latest results. To do this, 
simply press F5 on your keyboard. 

Topic Ratings 
With MadCap Feedback, users can give a rating to a topic, ranking it from not helpful to very helpful, 
using a sliding scale from 0 to 100 (for DotNet Help) or selecting from one to five stars (for Microsoft 
HTML Help, WebHelp, and WebHelp Plus). You can then view these ratings (which are displayed as a 
numerical score from 0 to 100) and make adjustments to the topics as necessary. They work hand-in-
hand with author-only comments, which can be entered at the same time that a topic is rated. 

 Rating topics (users) Learn how users submit ratings for topics in your online output. See 
"How End Users Submit Topic Ratings" on page 37. 

 Viewing topic ratings After users enter ratings for topics, you can view them in the Feedback 
Explorer. See "Viewing Topic Ratings" on page 38. 
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How End Users Submit Topic Ratings 

The following steps describe how end users submit topic ratings in the various output formats: DotNet 
Help, Microsoft HTML Help, WebHelp, and WebHelp Plus. 

How end users submit topic ratings in DotNet Help output 

1. In the DotNet Help output, the end user opens a topic. 

2. In the toolbar, the end user clicks the rating button . 

3. In the Rate Topic dialog, the end user clicks and drags the rating bar to the left or right.  

4. (Optional) The end user can also enter an author-only comment in the dialog.  

5. The end user clicks the Submit button. 

How end users submit topic ratings in Microsoft HTML Help output 

1. In the Microsoft HTML Help output, the end user opens a topic. 

2. In the toolbar directly above the topic, the end user clicks the rating button . 

3. In the Topic Rating popup, the end user clicks on the stars to provide a rating for the topic 
(giving the topic anywhere from one to five stars). 

4. (Optional) The end user can also enter an author-only comment in the area below. 

5. The end user clicks the Submit button. 

How end users submit topic ratings in WebHelp or WebHelp Plus output 

1. In the WebHelp or WebHelp Plus output, the end user opens a topic. 

2. In the toolbar, the end user clicks the rating button . 

3. In the Topic Rating popup, the end user clicks on the stars to provide a rating for the topic 
(giving the topic anywhere from one to five stars). 

4. (Optional) The end user can also enter an author-only comment in the area below. 

5. The end user clicks the Submit button. 

- 37 - 



MadCap Feedback • Getting Started Guide 

- 38 -  

Viewing Topic Ratings 

In the external Feedback Explorer, you can see each rating submitted for a topic, as well as the average 
rating for a topic. 

How to view all ratings for a topic 

1. Open the Feedback file. 

2. Open the Topics window. (If it is not already displayed in the interface, select View>Topics.) 

You can see information on the topic path, view count, comment count, average rating, and 
rating count. 

Note: You may need to refresh the window to make sure you see the latest results. To do 
this, simply press F5 on your keyboard. 

3. Double-click the topic whose ratings you want to view. 

The Topic View window opens. 

4. Select the Rating tab. 

All ratings and associated author-only comments for the topic are displayed in the tab. 
Individual ratings range from a score of 0 to 100, with 100 being the best rating. 

How to view the average rating for a topic 

1. Open the Feedback file. 

2. Open the Topics window. (If it is not already displayed in the interface, select View>Topics.) 

Note: You may need to refresh the window to make sure you see the latest results. To do 
this, simply press F5 on your keyboard. 

3. Resize the Topics window, or use the scroll bar at the bottom of the window to see the Avg 
Rating column. 

Individual ratings range from a score of 0 to 100, with 100 being the best rating. This column 
shows the average of all ratings combined. 
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Comments 
Users can enter comments on your Help topics. There are two types of comments: community-wide and 
author-only. 

 Community-wide comments A reader can enter a comment that may be viewed (and 
replied to) by all other users viewing the Help.  

o Controlling which comments are added to the output As the author, you have 
control over whether new community-wide user comments should be reviewed before 
they are displayed in the online output. If you specify that all incoming comments 
require review, those comments will have Pending status until you take action on them 
(e.g., accepting, discarding, hiding). If you specify that reviewing comments is not 
necessary, all incoming comments will automatically move to Accepted status and 
become immediately visible in your online output. You can always change the status of 
a community-wide comment, thereby affecting whether it is visible and to whom. See 
"How to specify whether new comments need to be reviewed" on page 41. 

o Enabling anonymous comments When users submit community-wide comments, 
they may be required to register, providing information such as name, user name, and 
email address. However, you can set up a Feedback file so that anonymous users will 
be accepted. In that case, users will not need to register; instead, they simply enter 
any user name when submitting a comment. See "How to enable anonymous 
comments" on page 41. 

o Entering community-wide comments (users) Learn how users submit these 
types of comments from your online output. See "How End Users Submit Community-
Wide Comments" on page 42. 

o Viewing community-wide comments After users enter community-wide 
comments, you can view them in the Feedback Explorer. This can be done from the 
Topic View window (which can be accessed by selecting View>Topics and then 
double-clicking a topic listed). On the Comments tab, all community-wide comments 
are displayed, including the status of each (e.g., Accepted, Pending Review, Hidden). 
You can also view pending community-wide comments. See "How to view all 
community-wide topic comments" on page 45 and "How to view pending community-
wide topic comments" on page 45. 

o Accepting pending comments If you set up MadCap Feedback so that new 
community-wide comments require approval before being added to the online output, 
those comments move to Pending status by default. Therefore, you must accept a 
comment before it is added to the online output to be viewed by everyone. Even after 
you accept a comment, you can later change your mind and assign a different status 
to it (Hidden, Pending Review) or discard it any time you want. See "How to accept 
pending community-wide comments" on page 46. 

o Hiding comments If you do not want a community-wide comment to be visible to all 
users in the community, but you also do not want to delete it from the system, you can 
change its status to Hidden. That way, you can continue to access the comment in the 
Feedback Explorer, but end users will not see it in the online output. You can assign a 
different status to it (Accepted, Pending Review) or discard it any time you want. See 
"How to hide community-wide comments" on page 47. 
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o Setting comments to Pending status If you set up MadCap Feedback so that new 
community-wide comments require approval before being added to the online output, 
those comments move to Pending status by default. This means that the comment is 
visible only to you and the end user until you accept it. If at any time the comment has 
a different status than Pending (i.e., Hidden, Accepted), you can send it back to the 
Pending Comments window by applying the Pending Review status to it. See "How to 
set comments to Pending status" on page 47. 

o Discarding comments If you do not want to keep a community-wide comment in the 
system, you can permanently delete it at any time. After you do this, you will no longer 
be able to access the comment. See "How to discard community-wide comments" on 
page 48. 

o Replying to community-wide comments After you receive community-wide 
comments from users, you can reply to them. You can either obtain the individual's 
email address and send a private response, or you can reply to the user from the 
online output so that everyone in the community sees your response. See "How to 
reply to a comment privately" on page 48 and "How to reply to a comment publicly" on 
page 49. 

o Viewing active users You can view a list of active users for your online Help. In 
other words, the list shows the users who have registered and submitted at least one 
community-wide comment. See "How to view active users" on page 49. 

Note: If you want end users to be able to enter community-wide Feedback comments in 
the online output and view recent comments, you need to enable community-wide 
comments. This is done by opening the skin in Flare that is associated with the target and 
selecting the appropriate option(s). For steps, see the online Help in Flare. 

 Author-only comments An end user can enter a comment that is intended for the Help 
author only. Each author-only comment is tied to a particular topic and works hand-in-hand 
with the topic ratings feature. Whereas community-wide comments can be seen by everyone in 
the output, an author-only comment can be accessed only from the Feedback Explorer. 
Therefore, only the Help author can view it.  

o Entering author-only comments (users) Learn how users submit these types of 
comments from your online output. See "How End Users Submit Author-Only 
Comments" on page 44. 

o Viewing author-only comments for a particular topic After a user enters an 
author-only comment, you can view it in the Feedback Explorer. See "How to view 
author-only topic comments" on page 46. 
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How to specify whether new comments need to be reviewed 

1. Open the Feedback file. 

2. In the Feedback Admin, select the Basic tab. 

3. Click the check box labeled Require new comments to be reviewed so that it contains a 
check mark. 

4. Click  to save your work. 

How to enable anonymous comments 

1. Open the Feedback file. 

2. In the Feedback Admin, select the Basic tab. 

3. Click the check box labeled Enable anonymous comments so that it contains a check mark. 

4. Click  to save your work. 
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How End Users Submit Community-Wide Comments 

The following steps describe how end users submit community-wide comments in the various output 
formats: DotNet Help, Microsoft HTML Help, WebHelp, and WebHelp Plus. 

How end users submit community-wide comments in DotNet Help output 

1. In the DotNet Help output, the end user opens a topic. 

2. The end user either clicks  in the local toolbar or selects  Help>Topic Comments. 

The Topic Comments window opens. 

3. In the window, the end user clicks the Add Comment button. 

4. If it is the user's first time submitting a community-wide comment, the user may be required to 
complete the registration process, providing information such as username, name, email 
address, and more. 

5. In the Add Comment dialog, the end user provides a subject and enters a comment. 

6. The end user clicks the Submit button. 

How end users submit community-wide comments in Microsoft HTML Help 
output 

1. In the Microsoft HTML Help output, the end user opens a topic. 

2. At the bottom of the topic, the end user clicks the Add Comment  button . 

3. If it is the user's first time submitting a community-wide comment, the user may be required to 
complete the registration process, providing information such as username, name, email 
address, and more. 

4. In the Add Comment dialog, the end user provides a subject and enters a comment. 

5. The end user clicks the Submit button. 
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How end users submit community-wide comments in WebHelp or WebHelp 
Plus output 

1. In the WebHelp or WebHelp Plus output, the end user opens a topic. 

2. The end user selects the Topic Comments bar. 

If you specify that comments should also be displayed at the bottom of each topic, users do not 
need to click the Topic Comments bar. For more information, see the Flare online Help. 

3. The end user does one of the following:  

 In the Topic Comments pane, the end user clicks the Add Comment button . 

OR 

 If you specified that comments should be displayed at the bottom of each topic, the 

end user clicks the Add Comment  button  at that location. 

4. In the Topic Comments pane, the end user clicks the Add Comment button . 

5. If it is the user's first time submitting a community-wide comment, the user may be required to 
complete the registration process, providing information such as username, name, email 
address, and more. 

6. In the Add Comment dialog, the end user provides a subject and enters a comment. 

7. The end user clicks the Submit button. 
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How End Users Submit Author-Only Comments 

The following steps describe how end users submit author-only comments in the various output 
formats: DotNet Help, Microsoft HTML Help, WebHelp, and WebHelp Plus. 

How end users submit author-only comments in DotNet Help output 

1. In the DotNet Help output, the end user opens a topic. 

2. In the toolbar, the end user clicks the rating button . 

3. In the Rate Topic dialog, the end user enters a comment.  

4. (Optional) The end user can also drag the rating bar from left to right to provide a rating for 
the topic.  

5. The end user clicks the Submit button. 

How end users submit author-only comments in Microsoft HTML Help output 

1. In the Microsoft HTML Help output, the end user opens a topic. 

2. In the toolbar directly above the topic, the end user clicks the rating button . 

3. In the Topic Rating popup, the end user clicks on the stars to provide a rating for the topic 
(giving the topic anywhere from one to five stars). 

4. The end user enters a comment in the area below. 

5. The end user clicks the Submit button. 

How end users submit author-only comments in WebHelp or WebHelp Plus 
output 

1. In the WebHelp or WebHelp Plus output, the end user opens a topic. 

2. In the toolbar, the end user clicks the rating button . 

3. In the Topic Rating popup, the end user clicks on the stars to provide a rating for the topic 
(giving the topic anywhere from one to five stars). 

4. The end user enters a comment in the area below. 

5. The end user clicks the Submit button. 
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Viewing Topic Comments 

The following steps describe how to view community-wide and author-only comments in the Feedback 
Explorer. For community-wide comments, this includes steps for viewing all such comments, as well as 
steps for viewing pending comments. 

How to view all community-wide topic comments 

1. Open the Feedback file. 

2. Open the Topics window. (If it is not already displayed in the interface, select View>Topics.) 

You can see information on the topic path, view count, comment count, average rating, and 
rating count. 

Note: You may need to refresh the window to make sure you see the latest results. To do 
this, simply press F5 on your keyboard. 

3. Double-click the topic whose comments you want to view. 

The Topic View window opens. 

4. Select the Comments tab. 

All community-wide comments for the topic are displayed in the tab. 

5. You can view the actual comment text by double-clicking the comment row, which opens the 
Properties dialog for community-wide comments. Alternatively, you can drag the divider to the 
right of the comment column in the window to see more of the text. 

How to view pending community-wide topic comments 

1. Open the Feedback file. 

2. Open the Pending Comments window. (If it is not already displayed in the interface, select 
View>Pending Comments.) 

The pending comments are listed in the bottom portion of the window. 

Note: You may need to refresh the window to make sure you see the latest results. To do 
this, simply press F5 on your keyboard. 

3. You can view the actual comment text by double-clicking the comment row, which opens the 
Properties dialog for community-wide comments. Alternatively, you can drag the divider to the 
right of the comment column in the window to see more of the text. 
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How to view author-only topic comments 

1. Open the Feedback file. 

2. Open the Topics window. (If it is not already displayed in the interface, select View>Topics.) 

You can see information on the topic path, view count, comment count, average rating, and 
rating count. 

Note: You may need to refresh the window to make sure you see the latest results. To do 
this, simply press F5 on your keyboard. 

3. Double-click the topic whose comments you want to view. 

The Topic View window opens. 

4. Select the Rating tab. 

All ratings and associated author-only comments for the topic are displayed in the tab. 

5. You can view the actual comment text by double-clicking the rating/comment row, which opens 
the Properties dialog for ratings and author-only comments. Alternatively, you can drag the 
divider to the right of the comment column in the window to see more of the text. 

How to accept pending community-wide comments 

1. Open the Feedback file. 

2. Open the Pending Comments window or Topic View window (Comments tab). 

 To open the Pending Comments window, select View>Pending Comments. 

 To open the Topic View window, open the Topics window (View>Topics). Then 
double-click the appropriate topic. Select the Comments tab. 

The comments are listed in the bottom portion of the window. 

Note: You may need to refresh the window to make sure you see the latest results. To do 
this, simply press F5 on your keyboard. 

3. Select a comment.  

You can view the actual comment text by double-clicking the comment row, which opens the 
Properties dialog for community-wide comments. Alternatively, you can drag the divider to the 
right of the comment column in the window to see more of the text. 

4. In the local toolbar, click the down arrow in the Set comment status field and select 
Accepted. 

5. Click Yes. 

The comment is removed from the Pending Comments window. When you or any users open 
the online output, that comment will be displayed. 
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How to hide community-wide comments 

1. Open the Feedback file. 

2. Open the Pending Comments window or Topic View window (Comments tab). 

 To open the Pending Comments window, select View>Pending Comments. 

 To open the Topic View window, open the Topics window (View>Topics). Then 
double-click the appropriate topic. Select the Comments tab. 

The comments are listed in the bottom portion of the window. 

Note: You may need to refresh the window to make sure you see the latest results. To do 
this, simply press F5 on your keyboard. 

3. Select a comment.  

You can view the actual comment text by double-clicking the comment row, which opens the 
Properties dialog for community-wide comments. Alternatively, you can drag the divider to the 
right of the comment column in the window to see more of the text. 

4. In the local toolbar, click the down arrow in the Set comment status field and select 
Hidden. 

5. Click Yes. The comment is not visible to any end users, but you can continue to view it in the 
Topic View window. 

How to set comments to Pending status 

1. Open the Feedback file. 

2. Open the Topics window (View>Topics). 

3. Double-click the appropriate topic. The Topic View window opens. 

4. Select the Comments tab. The comments are listed in the bottom portion of the window. 

Note: You may need to refresh the window to make sure you see the latest results. To do 
this, simply press F5 on your keyboard. 

5. Select a comment.  

You can view the actual comment text by double-clicking the comment row, which opens the 
Properties dialog for community-wide comments. Alternatively, you can drag the divider to the 
right of the comment column in the window to see more of the text. 

6. In the local toolbar, click the down arrow in the Set comment status field and select 
Pending Review. 

7. Click Yes. The comment is added to the Pending Comments window. 
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How to discard community-wide comments 

1. Open the Feedback file. 

2. Open the Pending Comments window or Topic View window (Comments tab). 

 To open the Pending Comments window, select View>Pending Comments. 

 To open the Topic View window, open the Topics window (View>Topics). Then 
double-click the appropriate topic. Select the Comments tab. 

The comments are listed in the bottom portion of the window. 

Note: You may need to refresh the window to make sure you see the latest results. To do 
this, simply press F5 on your keyboard. 

3. Select a comment. 

You can view the actual comment text by double-clicking the comment row, which opens the 
Properties dialog for community-wide comments. Alternatively, you can drag the divider to the 
right of the comment column in the window to see more of the text. 

4. In the local toolbar, click the Discard selected comments button . 

5. Click Yes. 

The comment is removed from the window and from the system. 

How to reply to a comment privately 

1. View the comment, and make note of the individual's user name.  

See "How to view all community-wide topic comments" on page 45 or "How to view pending 
community-wide topic comments" on page 45. 

2. View the list of active users (individuals who have registered and submitted at least one 
comment).  

See "How to view active users" on page 49. 

3. In the Active Users window, find the user and the corresponding email address in the list. 

You may need to drag the divider to the right of the E-Mail field to see the entire address. 

4. Send the user an email with your response to the comment. 

Note: In order to obtain the email addresses of your readers, make sure that anonymous 
comments are not enabled in the Feedback Admin. 
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How to reply to a comment publicly 

1. If necessary, accept the comment from the reader so that it displays in your online output.  

See "How to accept pending community-wide comments" on page 46. 

2. Open the topic in your published online output (just as your end users would). 

3. Find and select the comment to which you want to reply. 

 DotNet Help Select Help>Topic Comments. 

 HTML Help The comments are already displayed at the bottom of the topic. 

 WebHelp or WebHelp Plus Select the Topic Comments bar. 

4. Click the Reply to Comment button. 

 DotNet Help You may need to drag the divider in the window to see this button, 
which is displayed in the local toolbar. 

 HTML Help, WebHelp, or WebHelp Plus The button looks like this: . 

The Reply to Comment dialog opens.  

5. Enter a subject and a comment.  

6. Click Submit.  

7. If you have set up comments so that they require approval, you need to open the Feedback 
Explorer and approve your own comment.  

The comment will then be displayed under the original comment for all of your readers to see.  

How to view active users 

1. Open the Feedback file. 

2. Open the Active Users window. (If it is not already displayed in the interface, select 
View>Active Users.) 

The active users are listed in the bottom portion of the window. 

Note: You may need to refresh the window to make sure you see the latest results. To do this, 
simply press F5 on your keyboard. 
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Search 
With MadCap Feedback, you can determine how readers are using search in your online output. This 
helps you answer questions such as: What are they looking for? What are they finding? And more 
importantly, what are they unable to find? You can use the Feedback Explorer to view all used search 
phrases, as well as searches where no results were returned to the user. 

 Viewing used search phrases You can see statistics on all search phrases used, including 
the number of searches performed for each term and the number of results returned for users 
each time. This lets you know the information that users are seeking most often. You can then 
make the necessary adjustments to your project, such as adding more details to the 
appropriate topics. See "How to view used search phrases" on page 50. 

 Viewing searches without results You can see statistics on the search phrases for which 
users did not find results, including the number of searches performed for each term. See "How 
to view searches without results" on page 51. 

 Creating synonyms If users enter search phrases in your online output and those phrases 
are not returning results, this does not need to be the end of the story. You can make 
improvements to your output so that, in the future, users are able to find the search results 
they need. One way to make an enhancement is to add the information that your users are 
looking for (if that information does not yet exist in your Flare project). Another way to 
enhance your output is to create synonyms for search phrases. See "How to create synonyms" 
on page 51. 

You can create synonyms within the Flare project or within the external Feedback Explorer. It is 
not mandatory that you have MadCap Feedback in order to use synonyms in Flare output, but 
using MadCap Feedback makes it much easier to determine which words require synonyms 
based on the search results of your users. Using the external Feedback Explorer to create 
synonyms is appealing because the synonyms become immediately available for users 
searching in your output (without needing to republish the output). Be aware, however, that 
creating synonyms in the external Feedback Explorer works for the Feedback output as long as 
you continue to publish output to the same server. If you create synonyms in the external 
Feedback Explorer, it is recommended that you also create those synonyms at the source (i.e., 
within the Flare project), in case you ever publish to a different server. The easiest method is 
to export your synonyms to that Flare project. See "How to export synonyms" on page 59. 

Note: This feature is available if you are generating DotNet Help, WebHelp, or WebHelp Plus 
output formats only. It is not available for Microsoft HTML Help output. 

How to view used search phrases 

1. Open the Feedback file. 

2. Open the Search Phrases window. (If it is not already displayed in the interface, select 
View>Search Phrases.) 

You can see statistics on all search phrases used, including the number of searches performed 
for each term and the number of results returned for users each time. This lets you know the 
information that users are seeking most often. You can then make the necessary adjustments 
to your project, such as adding more details to the appropriate topics. 
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How to view searches without results 

1. Open the Feedback file. 

2. Open the Search Phrases with No Results window. (If it is not already displayed in the 
interface, select View>Search Phrases with no results.) 

You can see statistics on the search phrases for which users did not find results, including the 
number of searches performed for each term. 

How to create synonyms 

1. Open the Feedback file. 

2. Select View>Synonyms. 

The Synonyms Editor opens. 

3. You can create directional synonyms, and you can create synonym groups. 
 
Directional synonym This is a synonym that works in one direction (Word Synonym→ ). It is a 
useful method if readers enter a search term that is not contained in your project, but you have 
a similar word that is contained in the project. It works like this… In the Synonyms Editor, you 
enter the word that is not producing search results (because it is NOT contained in your project 
content). Next to it, you enter a synonym—a word that will produce search results (because it 
IS contained in your project content). When users enter the original word again in future 
searches, topics containing the synonym are found. 

E X A M P L E  

Let's say that you view search keyword results from your users and find that 
many are entering the search term "sofa." Unfortunately, you have not used 
that word in your project, so users are unable to f ind the topics that they 
need. However, you have used a similar word, "couch." Therefore, in the 
Synonyms Editor, you enter "couch" as a synonym for "sofa." The next t ime a 
reader enters "sofa" as a search keyword, topics containing the word "couch" 
wi l l  be returned in the results.  

a. Select the Directional tab. 

b. Click in the empty Word cell and press F2 on your keyboard. 

c. Type the phrase that users are entering when performing a search but not finding 
results (e.g., sofa). Press Enter when you are finished. 

d. Click in the empty Synonym cell and press F2 on your keyboard. 

e. Type the parallel search phrase that is contained in the project content (e.g., couch). 
Press Enter when you are finished. In the future, when users perform a search and 
enter the term from the Word cell (e.g., sofa), Flare will find all topics that contain the 
term that you entered in the Synonym cell (e.g., couch). 
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f. (Optional) Click in the Stem check box if you want Flare to accept other variations of 
the search term that have the same stem.  

E X A M P L E  

Let's say you enter "hike" in the Word cel l ,  and you enter "walk" in 
the Synonym cel l .  Then you select the Stem check box. In the future, 
i f  users search for the word "hike," i t  wi l l  f ind al l  topics containing the 
word "walk." The same wil l  happen i f  users enter other search phrases 
with the same stem, such as "hiked" or "hiking." 

Synonym group This is a collection of synonyms that produces the same search results for all 
of the words in the group. It is a useful method if you have multiple terms in your project that 
are similar, and you want the same search results to be returned when users enter any of those 
phrases. It works like this… In the Synonyms Editor, you enter the terms with an equal sign 
between each one (Synonym1=Synonym2=Synonym3=Synonym4). When users enter any of 
those terms in future searches, all topics containing any of those words are found. 

E X A M P L E  

Let's say that you have written some content about sports, and many of your 
topics include the words "sports," "athletics," or "games." If a user enters 
the word "athletics" as the search term, it wi l l  return not only topics 
containing that word, but also topics containing the words "sports" or 
"games" (even i f "athletics" does not occur in those other topics).  

a. Select the Groups tab. 

b. Click in the empty Group cell and press F2 on your keyboard. 

c. Type the words that you want to include in the group, with an equal sign between 
each (e.g., sports=athletics=games). Press Enter when you are finished. 

d. (Optional) Click in the Stem check box if you want Flare to find other variations of the 
synonyms that have the same stems.  

E X A M P L E  

Let's say you enter "hike=walk" in the Group cel l .  Then you select the 
Stem check box. In the future, i f  users search for the word "hike," it  
wi l l  f ind al l  topics containing the words "hike" or "walk." However, i t 
wi l l  also f ind topics containing words that have the same stem as 
those terms, such as "hiked," "hiking," or "walking." 

4. Click  to save your work.  
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Charts 
One great way to view end user statistics for your online documentation is to create and work with 
charts, which allow you to more easily recognize user trends.   

 Creating charts You can quickly transfer user statistics to many different kinds of color charts, 
making it easier to see at a glance how readers are using your online output. When you 
transfer user statistics to a chart, you can quickly change the type of chart that displays the 
information. This includes a variety of pie, donut, bar, cylinder, and line charts. See "How to 
create a Feedback chart" on page 54. 

 Editing chart styles After you create a chart, you can use the Chart Style Editor to modify the 
way it looks. You can modify a chart by including a grid, adding a shadow, modifying the 
spacing of elements, and changing the opacity. See "How to edit a Feedback chart" on page 
55. 

 Printing charts You can print charts created in the Feedback Explorer. See "How to print 
charts from the file menu" on page 56 and "How to print charts from the local toolbar" on page 
56. 
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How to create a Feedback chart 

1. Open the Feedback file. 

2. Open the window with the type of information that you want to view in a chart. Following are 
the different types of information for which you might create charts: 

 List of topics visited You can see information on the topic path, view count, 
comment count, average rating, and rating count. See "How to view topics opened by 
users" on page 36. 

 Search phrases You can see statistics on all search phrases used, including the 
number of searches performed for each term and the number of results returned for 
users each time. This lets you know the information that users are seeking most often. 
You can then make the necessary adjustments to your project, such as adding more 
details to the appropriate topics. See "How to view used search phrases" on page 50. 

 Search phrases with no results You can see statistics on the search phrases for 
which users did not find results, including the number of searches performed for each 
term. You might then create synonyms to enhance future results. See "How to view 
searches without results" on page 51. 

Note: You may need to refresh the window to make sure you see the latest results. To do 
this, simply press F5 on your keyboard. 

3. Select the rows of information that you want to include in the chart. You can select multiple 
rows by holding down the SHIFT or CTRL key and clicking a range of rows or individual rows. 

4. (Optional) You can specify the column information included in the chart. To do this, use the 
following steps: 

a. In the local toolbar, click . The Columns dialog opens. 

b. In the Chart column, click the check box to add a check mark next to each column 
that you want to include. 

c. Click OK. 

5. In the local toolbar, click . 

The Chart Window opens (by default on the right side of the interface). If necessary, you can 
click on the window divider and drag it to see more of the chart. 

6. Click the down arrow at the top of the Chart window to select the type of chart to display. 
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How to edit a Feedback chart 

1. Open the Feedback file. 

2. Create a Feedback chart by sending user statistics to the Chart window.  

See "How to create a Feedback chart" on page 54. 

3. In the local toolbar of the Chart window, click Edit Style. 

The Chart Style Editor opens, displaying a new chart file (with an .mcchart file extension). This 
file is stored by default in a subfolder named "My Chart Styles" (which is generated for you and 
placed in your My Documents folder). By default, the chart file is named after the type of graph 
that you have selected (e.g., Pie.mcchart). 

4. If you want to change the kind of chart being modified, select the Type tab. Then choose a 
new chart type from the list. 

5. On the Option tab, do any of the following: 
 
Add/remove a grid Some kinds of charts (such as bars and lines) are displayed by default 
with a grid, which helps to see the placement of values.  

 Click in the Draw Grid box to add or remove the check mark.  

Add/remove a shadow By default, elements in charts are displayed with shadows behind 
them to give the feeling of depth.  

 Click in the Draw Shadow box to add or remove the check mark.  

Change the spacing of elements You can change the width of certain chart elements (such 
as bars), making them thinner or wider.  

 Drag the Element Spacing bar to change the width. Moving the bar to the left makes 
the element thinner, whereas moving the bar to the right makes the element wider.  

Change the opacity of elements You can change how transparent or solid the chart 
elements look.  

 Drag the Element Opacity bar to the left or right. Moving the bar to the left makes 
the element more transparent, whereas moving the bar to the right makes the element 
more solid.  

6. Click  to save your work.  
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How to print charts from the file menu 

1. Create the Feedback chart. 

The Chart window opens. 

2. Select File>Print. 

3. Complete the options in the Print dialog. 

4. Click OK. 

How to print charts from the local toolbar 

1. Create the Feedback chart. 

The Chart window opens. 

2. Use the buttons in the local toolbar of the Chart window to specify settings and send the chart 
to the printer: 

  Opens the Print dialog, which lets you send the chart to a printer. After you make 
your selections in the dialog, click OK. 

 Print Preview Opens the Print Preview dialog, which lets you see how the Feedback 
chart will look when you print it. This includes the ability to zoom in and out. When you 

are finished in the dialog, either click  to send the chart to the printer or  to 
return to the Chart window. 

 Page Setup Opens the Page Setup dialog, which lets you specify different settings for 
the printed output, including the size, source, orientation, and margins. When you are 
finished in the dialog, click OK. 
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Exporting 
You can export Feedback data such as topics visited, comments, ratings, search terms used, and active 
users. You can also export synonyms that you have created to enhance user searches in the output. 

 Exporting data to Microsoft Excel (using a CSV file) After you accumulate data in the 
Feedback Explorer, you can export it to a comma-separated value (CSV) file. You can then 
open the file in Microsoft Excel. See "How to export Feedback data to Microsoft Excel (using a 
CSV file)" on page 57. 

 Exporting data to a tab-delimited text (TXT) file After you accumulate data in the 
Feedback Explorer, you can export it to a tab-delimited text (TXT) file. See "How to export 
Feedback data to a tab-delimited text file" on page 58. 

 Exporting synonyms After creating synonyms in the Feedback Explorer, you may want to 
export the synonyms file (MCSYNS) to another location. Those synonyms can then be added to 
the Flare project associated with the Feedback file, or even a different Flare project. See "How 
to export synonyms" on page 59. 

How to export Feedback data to Microsoft Excel (using a CSV file) 

1. Open the window whose data you want to export: 

 All topics visited (View>Topics) 

 All topic ratings (View>Topics; double-click topic row; select Ratings tab) 

 All author-only comments (View>Topics; double-click topic row; select Ratings tab) 

 All community-wide comments (View>Topics; double-click topic row; select 
Comments tab) 

 Pending comments (View>Pending Comments) 

 Active users (View>Active Users) 

 All search terms used (View>Search Phrases) 

 Search terms for which no results were found (View>Search Phrases with no 
results) 

2. Select the rows that you want to include in the export. You can hold down the SHIFT or CTRL 
key to select a range of rows or individual rows, respectively. 

3. Select File>Save To.  

The Save As dialog opens. 

4. Navigate to the location where you want to save the exported file. 

5. In the File name field, type a new name for the exported file. 

6. In the Save as type field, select Comma Delimited Text File (*.csv).  

7. Click Save. You can now open the file in Microsoft Excel. 
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How to export Feedback data to a tab-delimited text file 

1. Open the window whose data you want to export: 

 All topics visited (View>Topics) 

 All topic ratings (View>Topics; double-click topic row; select Ratings tab) 

 All author-only comments (View>Topics; double-click topic row; select Ratings tab) 

 All community-wide comments (View>Topics; double-click topic row; select 
Comments tab) 

 Pending comments (View>Pending Comments) 

 Active users (View>Active Users) 

 All search terms used (View>Search Phrases) 

 Search terms for which no results were found (View>Search Phrases with no 
results) 

2. Select the rows that you want to include in the export. You can hold down the SHIFT or CTRL 
key to select a range of rows or individual rows, respectively. 

3. Select File>Save To.  

The Save As dialog opens. 

4. Navigate to the location where you want to save the exported file. 

5. In the File name field, type a new name for the exported file. 

6. In the Save as type field, select Tab Delimited Text File (*.txt).  

7. Click Save.  
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How to export synonyms 

1. Open the Synonyms Editor by doing one of the following: 

 Select View>Synonyms. 

OR 

 Press CTRL+W on your keyboard. 

OR 

 In the Standard toolbar, click . 

2. Do one of the following: 

 Select File>Save As. 

OR 

 Select File>Save To. 

3. In the Save As dialog, navigate to the folder where you want to save the exported file. If you 
want to add the synonym file to a particular Flare project, you can navigate to the 
Project\Advanced subfolder where that project is stored. 

4. In the File name field, enter a name for the synonym file. 

5. Click Save. 
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